[Visual Studio] Fixing annoying bug [code 5455]

(Piszę ten post po angielsku bo może interesować dość szerokie grono odbiorców… A nie zajmuję się w nim jakąś wielką filozofią by nie wystarczyła podstawowa znajomość lengłydża.)

Today, when I’d started my PC after yesterday’s Windows 7 / Office updates I started my VS 2013 Update 3 and tried working on some project. But whenever I tried opening file with code I’ve been given a strange error message. From the message it looked like some problems with settings. So I tried to make a screenshot of the error window (because of locking focus) and pasted it into MS Paint. This is what I’ve got:
Error_Message

Ok, I had my phone with me so I was able to work around the issue:
Error_Message_Camera

Now I was able to go to the Options and try to find what might cause it. Unfortunately most of tabs had not been working and some (“All Languages” if I recall correctly) even caused VS to restart… Then I decided to reset all settings. And then I received something similar to what was described several months ago in following ticket:
Cannot open any code files

When I try to open up a C# code file an error pops up. The error that occurs states that “No EditorOptionDefinition export found for the given option name: Adornments/HighlightCurrentLine/Enable Parameter name: optionId”
I tried to reset my settings but I then received the following error “Your settings were reset, but there were some errors.
Error 1: Task List Display Settings: The tasklist format has changed.
Error 2: An error occurred while importing settings for ‘All Languages’ [code 5455&#93.
Error 3: An error occurred while importing settings for ‘Basic’ [code 5455&#93.
Error 4: An error occurred while importing settings for ‘C/C++’ [code 5455&#93.
Error 5: An error occurred while importing settings for ‘CSS’ [code 5455&#93.
Error 6: An error occurred while importing settings for ‘C#’ [code 5455&#93.
Error 7: An error occurred while importing settings for ‘CoffeeScript’ [code 5455].
Error 8: An error occurred while importing settings for ‘F#’ [code 5455&#93.
(…)
Error 18: An error occurred while importing settings for ‘XAML’ [code 5455&#93.
Error 19: An error occurred while importing settings for ‘XML’ [code 5455&#93.”

(I added a bit of formatting to exaggerate core issues.)

Continue reading [Visual Studio] Fixing annoying bug